Konfigurasi SSH dan Telnet pada Cisco

Konfigurasi SSH dan Telnet pada Cisco

Cisco

 

Hallo sobat engineer, ketemu lagi dengan kami. Kali ini kami akan memberikan tutorial konfigurasi Remote Telnet dan SSH Pada Cisco.

Telnet

Apa itu telnet ? telnet yaitu kependekan dari Telecommunications Network Protocol untuk remote login yang terjadi di jaringan internet, jadi istilahnya anda bisa mengremote atau mengakses komputer atau device lain dari internet dari jarak jauh sekalipun asalkan terdapat access internet.

 

Analoginya seperti anda bekerja pada sebuah perusahaan dalam bidang IT dan anda masuk dalam divisi sistem admin dimana anda harus selalu memantau dan mengecek server kapanpun waktunya, sedangkan jarak anda ke kantor itu misalkan kurang lebih 2 jam perjalanan. Nah disinilah fitur telnet dapat digunakan agar anda tidak perlu bolak balik menuju kantor, jadi anda bisa memonitoring dan melakukan pekerjaan anda dari rumah asalkan dirumah anda ada access internet dan perangkat yang diremote tersebut memiliki IP Public untuk dapat diakses lewat internet.

 

Telnet mempunyai kelebihan dan juga kekurangan, kelebihannya yaitu anda bisa mengakses perangkat dari jarak jauh sekalipun dengan menggunakan terminal untuk meremotenya dengan basic command line, kekurangannya yaitu tidak adanya fitur enkripsi sehingga dapat memudahkan para hacker untuk melakukan pencurian password.

SSH

Apa itu SSH ? ssh adalah aplikasi pengganti remote login seperti telnet, rsh, dan rlogin, yang jauh lebih aman. Fungsi utama aplikasi ini adalah untuk mengakses mesin secara remote. Sama seperti telnet, SSH Client juga menyediakan User dengan Shell untuk remote ke mesin. Tidak seperti telnet, SSH menyediakan koneksi enkripsi antara klien dengan server. Dalam prakteknya, penggunaan menggunakan telnet dan ssh seperti perbedaan dengan mengakses website biasa dengan website yang lebih aman (HTTPS).

Konfigurasi Cisco

Berikut merupakan topologi yang digunakan untuk konfigurasi telnet dan ssh. Kita akan menggunakan router semarang.
topologi
Langkah pertama kalian masuk kedalam konfigurasi router menggunakan kabel line console, klik ok

Selanjutnya kita membuat sebuah autentikasi login jika ada yang masuk melalui kabel console dan line console dengan konfigurasi berikut

Line console 0 = Line kabel konsol
Password = Password Login
Login = Perintah agar login terlebih dahulu sebelum mengakses
Exec-timeout 5 0 = Perintah agar setelah 5 menit 0 detik yang mengakses router
tersebut akan keluar dengan sendirinya.

Berikut hasil dari konfigurasi setiap orang yang ingin masuk ke dalam router dengan kabel console akan diminta password terlebih dahulu

Langkah kedua kita akan konfigurasi autentikasi login pada mode privalaged dengan konfigurasi berikut

Enable secret nevtikadmin = Membuat password dengan di enkripsikan passwordnya.
Service password-encryption = Menjadikan seluruh password yang sudah dibuat menjadi terenkripsi.

Setelah memasukkan konfigurasi “Service password-encryption” maka password yang kita buat sebelumnya akan terenkripsi seperti ini, ini adalah hasil enkripsi dari password line console 0 hal ini menjadi menyulitkan para pencari password dan menambah tingkat keamanan sebuah device tersebut.
Berikut hasil konfigurasi autentikasi login privalaged

 

 

Langkah ketiga kita akan mulai konfigurasi untuk telnet dan ssh dengan konfigurasi berikut

 

Line vty 0 4 = Virtual interface untuk mengremote lewat internet.
Line vty 0 4 artinya bisa ada 5 koneksi yang mengremote device tersebut secara bersamaan (0 – 4 ada 5 bilangan yaitu 0, 1, 2, 3, 4)
Maksimalnya ada 16 koneksi yaitu (0 – 15)
Password nevtikadmin = Merupakan password untuk telnet tersebut
Login local = Merupakan userlogin yang sudah dibuat dirouter tersebut
Exec-timeout 5 0 = Merupakan timer 5 menit 0 detik, apabila yang
mengremote tersebut tidak melakukan apa-apa selama 5 menit 0 detik maka dia akan keluar dengan sendirinya.
Username admin password nevtik admin = merupakan userlogin yang dibuat untuk login dan mengremot device tersebut.

Selanjutnya tambahkan IP Address untuk device tersebut dan jangan lupa untuk tambahkan ip pada client juga dengan satu jaringan

 

Interface fastethernet 0/0 = adalah interface yang akan kita buat ip addressnya
IP address 20.20.20.254 = adalah ip address yang akan dibuat untuk interface tersebut
255.255.255.0 = Merupakan subnet mask untuk ip tersebut
No shutdown = Merupakan perintah untuk mengaktifkan interface tersebut

Berikut hasil dari konfigurasi tersebut dan meremote menggunakan telnet

Selanjutnya kita buat  crypto key dan ip domain-name yang bertujuan untuk remote ssh.

Crypto key generate rsa adalah pemberian bit untuk Panjang dari key data, minimalnya adalah 512 dan maksimalnya adalah 1024, semakang Panjang key tersebut maka akan semakin aman dan semaking bagus akan tetapi semakin membebani device tersebut. Berikut hasil dari konfigurasi ssh.

 

SSH -l admin = (-l artinya login) (admin adalah user yang kita buat tadi)
20.20.20.254 = adalah ip device tersebut yang akan digunakan untuk remote.

Konfigurasi VLAN Pada Cisco

Konfigurasi VLAN Pada Cisco

Cisco

Hallo sobat engineers, Nevtik kembali lagi dengan tutorial kali ini yaitu konfigurasi VLAN pada cisco. Sebelum kita masuk ke dalam konfigurasi VLAN, kita harus mengetahui apa itu VLAN ?

VLAN

VLAN merupakan singkatan dari Virtual LAN, maka LAN yang dibuat berbentuk virtual.Jika kita menggunakan switch unmanageable untuk membuat 2 jaringan yang berbeda tentunya kita membutuhkan 2 switch, berbeda dengan switch manageable, kita dapat membuat beberapa network sekaligus dalam 1 switch dengan menggunakan VLAN.

Konfigurasi Switch

Konfigurasi vlan cisco
Disini terdapat sebuah topologi VLAN yang akan kita konfigurasikan, terdapat 2 buah VLAN yaitu VLAN 10 dan VLAN 20, secara default switch telah memiliki 1 buah VLAN yaitu VLAN 1 yang anggotanya seluruh interface yang ada pada switch.
Langkah pertama yaitu kita buat VLAN 10 menggunakan config seperti gambar dibawah ini:
  • enable merupakan command untuk masuk kedalam privellage mode, ditandai dengan tanda “#”
  • configure terminal merupakan command untuk masuk kedalam global mode, ditandai dengan “config”
  • vlan 10 merupakan command untuk masuk kedalam vlan
  • name merupakan command untuk membuat nama pada VLAN,pada VLAN 10 diberi nama nevtik, pemberian nama bebas
  • interface range fa0/2-fa0/3 merupakan command untuk memasukan 2  interface sekaligus kedalam VLAN
  • switchport access vlan 10 memberikan akses VLAN kepada interface yang sudah dimasukan
  • exit command untuk keluar
Selanjutnya yaitu membuat VLAN 20,confignya sama seperti ketika membuat VLAN 10 yang membedakan hanya interface mana yang akan dimasukan sebagai anggota VLAN.
  • vlan 20 masuk kedalam vlan
  • name tkj memberi nama pada vlan yaitu tkj
  • interface range fa0/4-fa0/5 memasukan interface kedalam vlan
  • switchport access vlan 20 memberikan akses vlan kepada interface
Setelah itu kita tambahkan trunk pada interface fa0/1, interface ini mengarah ke router fungsi dari ttrunk ini yaitu membawa VLAN yang ada pada switch ke router, agar nantinya VLAN yang berbeda dapat saling terhubung, namun perbedaan mode trunk dan mode access yaitu jika mode access hanya membawa 1 VLAN saja, sedangkan mode trunk dapat membawa beberapa VLAN sekaligus.
  • interface fa0/1 masuk kedalam interface yang mengarah ke router
  • switchport mode trunk menambahkan mode trunk pada interface
  • switchport trunk allowed vlan all merupakan command agar semua VLAN dapat melewati trunk tersebut
Sekarang konfigurasi ip pada setiap pc, namun ip 10.10.1.1 dan 20.20.1.1 jangan digunakan pada client karna ip tersebut akan dijadikan gateway bagi setiap VLAN. Lalu tes ping ke pc yang berada dalam satu VLAN pastikan sudah bisa saling ping, ping juga ke pc yang berbeda VLAN.
Hasilnya gagal/rto mengapa demikian?, karena jika tidak ada router yang dijadikan gateway maka VLAN yang berbeda tidak akan bisa saling ping kecuali switch yang digunakan yaitu switch multilayer/switch layer 3.

Konfigurasi Switch

Selanjutnya kita konfigurasikan subinterface pada interface router yang mengarah ke switch, fungsi subinterface yaitu sebagai gateway yang akan dipakai oleh client agar VLAN yang berbeda dapat saling terhubung.
  • kabel yang menghubungkan switch dengan router masih berwarna merah, yang menandakan interface router masih down, untuk mengaktifkannya masuk terlebih dahulu kedalam interface fa0/1 dan aktifkan menggunakan command no shutdown
Setelah aktif kita konfigurasi subinterface pada interface fa0/0
  • interface fa0/0.10 command menambahkan subinterface,angka 10 merupakan VLAN 10
  • encapsulation dot1Q 10 command mengencapsulasi VLAN 10 dengan dengan tipe encapsulasi dot1Q(802.1q)
  • masukan ip address beserta netmasknya yang akan dijadikan gateway
  • lalu exit untuk keluar

Setelah subinterface selesai,sekarang tes ping ke pc yang berbeda VLAN awalnya memang time out, tetapi setalah time out pasti reply karena VLAN 10 mencari dulu mac address dari pc VLAN 20.